Vulnerability · Published Jan 28, 2020 · Assigned by GitHub_M

CVE-2020-5210NetHack command line -w option parsing is subject to a buffer overflow

Medium 5.0

In plain English

A medium-severity buffer overflow in NetHack from NetHack. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.0Medium
Exploit odds (30 days)0.8%top 43.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In NetHack before 3.6.5, an invalid argument to the -w command line option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to influence command line options. Users should upgrade to NetHack 3.6.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12nethack3.6.6-1DEBIAN-CVE-2020-5210
Debian:13nethack3.6.6-1DEBIAN-CVE-2020-5210
Debian:14nethack3.6.6-1DEBIAN-CVE-2020-5210

Affected products (as reported)

VendorProductVersions
NetHack NetHack < 3.6.5

Weakness: CWE-120 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L

References