Vulnerability · Published Jan 28, 2020 · Assigned by GitHub_M
CVE-2020-5209NetHack command line parsing of options starting with -de and -i is subject to a buffer overflow
Medium 5.0
In plain English
A medium-severity buffer overflow in NetHack from NetHack. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In NetHack before 3.6.5, unknown options starting with -de and -i can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to influence command line options. Users should upgrade to NetHack 3.6.5.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | nethack | 3.6.6-1 | DEBIAN-CVE-2020-5209 |
| Debian:13 | nethack | 3.6.6-1 | DEBIAN-CVE-2020-5209 |
| Debian:14 | nethack | 3.6.6-1 | DEBIAN-CVE-2020-5209 |
Affected products (as reported)
Weakness: CWE-120 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L