Vulnerability · Published Jun 22, 2020 · Assigned by GitHub_M
CVE-2020-4066Command Injection in Limdu trainBatch function
Low 3.8
In plain English
A low-severity OS command injection in Limdu from erelsgl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)3.8Low
Exploit odds (30 days)1.6%top 23.7% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
In Limdu before 0.95, the trainBatch function has a command injection vulnerability. Clients of the Limdu library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability. This has been patched in 0.95.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | limdu | 0.9.5 | GHSA-77qv-gh6f-pgh4 |
Affected products (as reported)
Weakness: CWE-78 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
References
- https://github.com/erelsgl/limdu/security/advisories/GHSA-77qv-gh6f-pgh4 x_refsource_CONFIRM