Vulnerability · Published Jun 15, 2020 · Assigned by GitHub_M

CVE-2020-4051XSS in Dijit Editor's LinkDialog plugin

Low 3.7

In plain English

A low-severity cross-site scripting in dijit from Dojo. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)1.2%top 32.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In Dijit before versions 1.11.11, and greater than or equal to 1.12.0 and less than 1.12.9, and greater than or equal to 1.13.0 and less than 1.13.8, and greater than or equal to 1.14.0 and less than 1.14.7, and greater than or equal to 1.15.0 and less than 1.15.4, and greater than or equal to 1.16.0 and less than 1.16.3, there is a cross-site scripting vulnerability in the Editor's LinkDialog plugin. This has been fixed in 1.11.11, 1.12.9, 1.13.8, 1.14.7, 1.15.4, 1.16.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12dojo1.15.4+dfsg1-1DEBIAN-CVE-2020-4051
Debian:13dojo1.15.4+dfsg1-1DEBIAN-CVE-2020-4051
Debian:14dojo1.15.4+dfsg1-1DEBIAN-CVE-2020-4051
Ubuntu:22.04:LTSdojo1.15.4+dfsg1-1ubuntu0.1USN-7569-1
npmdijit1.14.7GHSA-cxjc-r2fp-7mq6
npmdijit1.15.4GHSA-cxjc-r2fp-7mq6
npmdijit1.16.3GHSA-cxjc-r2fp-7mq6
npmdijit1.13.8GHSA-cxjc-r2fp-7mq6
npmdijit1.12.9GHSA-cxjc-r2fp-7mq6
npmdijit1.11.11GHSA-cxjc-r2fp-7mq6

Affected products (as reported)

VendorProductVersions
Dojo dijit < 1.11.11>= 1.12.0, < 1.12.9>= 1.13.0, < 1.13.8>= 1.14.0, < 1.14.7>= 1.15.0, < 1.15.4>= 1.16.0, < 1.16.3

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N

References