Vulnerability · Published Mar 31, 2024 · Assigned by VulDB
CVE-2020-36828DiscuzX install_function.php show_next_step cross site scripting
Low 3.5
In plain English
A low-severity cross-site scripting in DiscuzX. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities).
Official description
A vulnerability was found in DiscuzX up to 3.4-20200818. It has been classified as problematic. Affected is the function show_next_step of the file upload/install/include/install_function.php. The manipulation of the argument uchidden leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 3.4-20210119 is able to address this issue. The name of the patch is 4a9673624f46f7609486778ded9653733020c567. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-258612.
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
References
- VDB-258612 | DiscuzX install_function.php show_next_step cross site scripting vdb-entry, technical-description
- VDB-258612 | CTI Indicators (IOB, IOC, TTP, IOA) signature, permissions-required
- https://github.com/codersclub/DiscuzX/commit/4a9673624f46f7609486778ded9653733020c567 patch