Vulnerability · Published Dec 30, 2020 · Assigned by GitHub_M
CVE-2020-26296XSS in Vega
High 8.7
In plain English
A high-severity cross-site scripting in vega from vega. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.7% (higher than 77% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Vega in an npm package. In Vega before version 5.17.3 there is an XSS vulnerability in Vega expressions. Through a specially crafted Vega expression, an attacker could execute arbitrary javascript on a victim's machine. This is fixed in version 5.17.3
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | vega | 5.17.3 | GHSA-r2qc-w64x-6j54 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
References
- https://github.com/vega/vega/security/advisories/GHSA-r2qc-w64x-6j54 x_refsource_CONFIRM
- https://github.com/vega/vega/issues/3018 x_refsource_MISC
- https://github.com/vega/vega/pull/3019 x_refsource_MISC
- https://github.com/vega/vega/releases/tag/v5.17.3 x_refsource_MISC
- https://www.npmjs.com/package/vega x_refsource_MISC