Vulnerability · Published Dec 10, 2020 · Assigned by GitHub_M

CVE-2020-26270CHECK-fail in LSTM with zero-length input in TensorFlow

Medium 4.4

In plain English

A medium-severity improper input validation in tensorflow from tensorflow. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.4Medium
Exploit odds (30 days)0.2%top 93.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In affected versions of TensorFlow running an LSTM/GRU model where the LSTM/GRU layer receives an input with zero-length results in a CHECK failure when using the CUDA backend. This can result in a query-of-death vulnerability, via denial of service, if users can control the input to the layer. This is fixed in versions 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2, and 2.4.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPItensorflow2.1.3GHSA-m648-33qf-v3gp
PyPItensorflow2.2.2GHSA-m648-33qf-v3gp
PyPItensorflow2.3.2GHSA-m648-33qf-v3gp
PyPItensorflow1.15.5GHSA-m648-33qf-v3gp
PyPItensorflow1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2PYSEC-2020-256
PyPItensorflow2.0.4GHSA-m648-33qf-v3gp
PyPItensorflow-cpu2.3.2GHSA-m648-33qf-v3gp
PyPItensorflow-cpu1.15.5GHSA-m648-33qf-v3gp
PyPItensorflow-cpu2.0.4GHSA-m648-33qf-v3gp
PyPItensorflow-cpu2.1.3GHSA-m648-33qf-v3gp
PyPItensorflow-cpu2.2.2GHSA-m648-33qf-v3gp
PyPItensorflow-cpu1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2PYSEC-2020-301
PyPItensorflow-gpu2.1.3GHSA-m648-33qf-v3gp
PyPItensorflow-gpu2.2.2GHSA-m648-33qf-v3gp
PyPItensorflow-gpu2.3.2GHSA-m648-33qf-v3gp
PyPItensorflow-gpu1.15.5GHSA-m648-33qf-v3gp
PyPItensorflow-gpu1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2PYSEC-2020-336
PyPItensorflow-gpu2.0.4GHSA-m648-33qf-v3gp

Affected products (as reported)

VendorProductVersions
tensorflow tensorflow < 1.15.5>= 2.0.0, < 2.0.4>= 2.1.0, < 2.1.3>= 2.2.0, < 2.2.2>= 2.3.0, < 2.3.2

Weakness: CWE-20 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L

References