Vulnerability · Published Dec 10, 2020 · Assigned by GitHub_M
CVE-2020-26266Uninitialized memory access in Eigen types in TensorFlow
Medium 4.4
In plain English
A medium-severity security flaw in tensorflow from tensorflow. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In affected versions of TensorFlow under certain cases a saved model can trigger use of uninitialized values during code execution. This is caused by having tensor buffers be filled with the default value of the type but forgetting to default initialize the quantized floating point types in Eigen. This is fixed in versions 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2, and 2.4.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | tensorflow | 2.1.3 | GHSA-qhxx-j73r-qpm2 |
| PyPI | tensorflow | 2.2.2 | GHSA-qhxx-j73r-qpm2 |
| PyPI | tensorflow | 2.3.2 | GHSA-qhxx-j73r-qpm2 |
| PyPI | tensorflow | 1.15.5 | GHSA-qhxx-j73r-qpm2 |
| PyPI | tensorflow | 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 | PYSEC-2020-254 |
| PyPI | tensorflow | 2.0.4 | GHSA-qhxx-j73r-qpm2 |
| PyPI | tensorflow-cpu | 2.3.2 | GHSA-qhxx-j73r-qpm2 |
| PyPI | tensorflow-cpu | 1.15.5 | GHSA-qhxx-j73r-qpm2 |
| PyPI | tensorflow-cpu | 2.0.4 | GHSA-qhxx-j73r-qpm2 |
| PyPI | tensorflow-cpu | 2.1.3 | GHSA-qhxx-j73r-qpm2 |
| PyPI | tensorflow-cpu | 2.2.2 | GHSA-qhxx-j73r-qpm2 |
| PyPI | tensorflow-cpu | 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 | PYSEC-2020-297 |
| PyPI | tensorflow-gpu | 2.1.3 | GHSA-qhxx-j73r-qpm2 |
| PyPI | tensorflow-gpu | 2.2.2 | GHSA-qhxx-j73r-qpm2 |
| PyPI | tensorflow-gpu | 2.3.2 | GHSA-qhxx-j73r-qpm2 |
| PyPI | tensorflow-gpu | 1.15.5 | GHSA-qhxx-j73r-qpm2 |
| PyPI | tensorflow-gpu | 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 | PYSEC-2020-332 |
| PyPI | tensorflow-gpu | 2.0.4 | GHSA-qhxx-j73r-qpm2 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| tensorflow | tensorflow | < 1.15.5>= 2.0.0, < 2.0.4>= 2.1.0, < 2.1.3>= 2.2.0, < 2.2.2>= 2.3.0, < 2.3.2 |
Weakness: CWE-908 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L