Vulnerability · Published Dec 9, 2020 · Assigned by GitHub_M

CVE-2020-26261user-readable api tokens in systemd units

High 7.9

In plain English

A high-severity security flaw in systemdspawner from jupyterhub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.9High
Exploit odds (30 days)0.5%top 58.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

jupyterhub-systemdspawner enables JupyterHub to spawn single-user notebook servers using systemd. In jupyterhub-systemdspawner before version 0.15 user API tokens issued to single-user servers are specified in the environment of systemd units. These tokens are incorrectly accessible to all users. In particular, the-littlest-jupyterhub is affected, which uses systemdspawner by default. This is patched in jupyterhub-systemdspawner v0.15

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIjupyterhub-systemdspawner0.15.0GHSA-cg54-gpgr-4rm6
PyPIjupyterhub-systemdspawner0.15.0PYSEC-2020-52

Affected products (as reported)

VendorProductVersions
jupyterhub systemdspawner < 0.15

Weakness: CWE-668 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

References