Vulnerability · Published Dec 30, 2020 · Assigned by GitHub_M

CVE-2020-26247XXE in Nokogiri

Low 2.6

In plain English

A low-severity XML external entity in nokogiri from sparklemotion. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)2.6Low
Exploit odds (30 days)1.2%top 32.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Nokogiri is a Rubygem providing HTML, XML, SAX, and Reader parsers with XPath and CSS selector support. In Nokogiri before version 1.11.0.rc4 there is an XXE vulnerability. XML Schemas parsed by Nokogiri::XML::Schema are trusted by default, allowing external resources to be accessed over the network, potentially enabling XXE or SSRF attacks. This behavior is counter to the security policy followed by Nokogiri maintainers, which is to treat all input as untrusted by default whenever possible. This is fixed in Nokogiri version 1.11.0.rc4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20ruby-nokogiri1.11.6-r0ALPINE-CVE-2020-26247
Alpine:v3.21ruby-nokogiri1.11.6-r0ALPINE-CVE-2020-26247
Alpine:v3.22ruby-nokogiri1.11.6-r0ALPINE-CVE-2020-26247
Alpine:v3.23ruby-nokogiri1.11.6-r0ALPINE-CVE-2020-26247
Alpine:v3.24ruby-nokogiri1.11.6-r0ALPINE-CVE-2020-26247
Debian:12ruby-nokogiri1.11.1+dfsg-1DEBIAN-CVE-2020-26247
Debian:13ruby-nokogiri1.11.1+dfsg-1DEBIAN-CVE-2020-26247
Debian:14ruby-nokogiri1.11.1+dfsg-1DEBIAN-CVE-2020-26247
RubyGemsnokogiri1.11.0GHSA-vr8q-g5c7-m54m

Affected products (as reported)

VendorProductVersions
sparklemotion nokogiri < 1.11.0.rc4

Weakness: CWE-611 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N

References