Vulnerability · Published Nov 13, 2020 · Assigned by GitHub_M

CVE-2020-26223Authorization bypass in Spree

High 7.7

In plain English

A high-severity incorrect authorization in spree from spree. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)1.1%top 33.6% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Spree is a complete open source e-commerce solution built with Ruby on Rails. In Spree from version 3.7 and before versions 3.7.13, 4.0.5, and 4.1.12, there is an authorization bypass vulnerability. The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token. This is patched in versions 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsspree_api3.7.13GHSA-m2jr-hmc3-qmpr
RubyGemsspree_api4.0.5GHSA-m2jr-hmc3-qmpr
RubyGemsspree_api4.1.12GHSA-m2jr-hmc3-qmpr

Affected products (as reported)

VendorProductVersions
spree spree >= 3.7.0, < 3.7.13>= 4.0.0, < 4.0.5>= 4.1.0, < 4.1.12

Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

References