Vulnerability · Published Nov 16, 2020 · Assigned by GitHub_M

CVE-2020-26217Remote Code Execution in XStream

High 8.0

In plain English

A high-severity OS command injection in xstream from x-stream. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 85.0% (higher than 99.7% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.0High
Exploit odds (30 days)85.0%top 0.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling2Nuclei, Public PoC

Official description

XStream before version 1.4.14 is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker to run arbitrary shell commands only by manipulating the processed input stream. Only users who rely on blocklists are affected. Anyone using XStream's Security Framework allowlist is not affected. The linked advisory provides code workarounds for users who cannot upgrade. The issue is fixed in version 1.4.14.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12libxstream-java1.4.14-1DEBIAN-CVE-2020-26217
Debian:13libxstream-java1.4.14-1DEBIAN-CVE-2020-26217
Debian:14libxstream-java1.4.14-1DEBIAN-CVE-2020-26217
Mavencom.thoughtworks.xstream:xstream1.4.14-java7GHSA-mw36-7c6c-q4q2

Affected products (as reported)

VendorProductVersions
x-stream xstream < 1.4.14

Weakness: CWE-78 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H

References