Vulnerability · Published Nov 3, 2020 · Assigned by GitHub_M
CVE-2020-26210Cross-Site Scripting in BookStack
High 7.7
In plain English
A high-severity cross-site scripting in BookStack from BookStackApp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities).
Official description
In BookStack before version 0.30.4, a user with permissions to edit a page could add an attached link which would execute untrusted JavaScript code when clicked by a viewer of the page. Dangerous content may remain in the database after this update. If you think this could have been exploited the linked advisory provides a SQL query to test. As a workaround, page edit permissions could be limited to only those that are trusted until you can upgrade although this will not address existing exploitation of this vulnerability. The issue is fixed in version 0.30.4.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| BookStackApp | BookStack | < 0.30.4 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N
References
- https://github.com/BookStackApp/BookStack/security/advisories/GHSA-7p2j-4h6p-cq3h x_refsource_CONFIRM
- https://github.com/BookStackApp/BookStack/commit/349162ea139556b2d25e09e155cec84e21cc9227 x_refsource_MISC
- https://bookstackapp.com/blog/beta-release-v0-30-4/ x_refsource_MISC
- https://github.com/BookStackApp/BookStack/releases/tag/v0.30.4 x_refsource_MISC