Vulnerability · Published Nov 19, 2020 · Assigned by redhat

CVE-2020-25700

Medium 6.5

In plain English

A medium-severity SQL injection in moodle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)6.5Medium
Exploit odds (30 days)1.3%top 28.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In moodle, some database module web services allowed students to add entries within groups they did not belong to. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.8.6, 3.7.9, 3.5.15, and 3.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistmoodle/moodle3.9.3GHSA-7h8v-2v8x-h264
Packagistmoodle/moodle3.8.6GHSA-7h8v-2v8x-h264
Packagistmoodle/moodle3.7.9GHSA-7h8v-2v8x-h264
Packagistmoodle/moodle3.5.15GHSA-7h8v-2v8x-h264

Affected products (as reported)

VendorProductVersions
n/a moodle Fixed in 3.9.3Fixed in 3.8.6Fixed in 3.7.9Fixed in 3.5.15Fixed in 3.10

Weakness: CWE-89

References