Vulnerability · Published Nov 19, 2020 · Assigned by redhat
CVE-2020-25699
High 7.5
In plain English
A high-severity incorrect authorization in moodle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)7.5High
Exploit odds (30 days)1.6%top 24.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
In moodle, insufficient capability checks could lead to users with the ability to course restore adding additional capabilities to roles within that course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | moodle/moodle | 3.9.3 | GHSA-h77r-rp97-7rv4 |
| Packagist | moodle/moodle | 3.8.6 | GHSA-h77r-rp97-7rv4 |
| Packagist | moodle/moodle | 3.7.9 | GHSA-h77r-rp97-7rv4 |
| Packagist | moodle/moodle | 3.5.15 | GHSA-h77r-rp97-7rv4 |
Affected products (as reported)
Weakness: CWE-863