Vulnerability · Published Dec 8, 2020 · Assigned by redhat
CVE-2020-25629
High 8.8
In plain English
A high-severity improper access control in Moodle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 71% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)8.8High
Exploit odds (30 days)1.3%top 29.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access to some site administration capabilities by "logging in as" a System manager. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. This is fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | moodle/moodle | 3.9.2 | GHSA-f5r8-7h4f-jr9x |
| Packagist | moodle/moodle | 3.8.5 | GHSA-f5r8-7h4f-jr9x |
| Packagist | moodle/moodle | 3.7.8 | GHSA-f5r8-7h4f-jr9x |
| Packagist | moodle/moodle | 3.5.14 | GHSA-f5r8-7h4f-jr9x |
Affected products (as reported)
Weakness: CWE-284
References
- https://moodle.org/mod/forum/discuss.php?d=410841 x_refsource_CONFIRM