Vulnerability · Published Mar 23, 2020 · Assigned by apache

CVE-2020-1944

Critical 9.8

In plain English

A critical-severity security flaw in Apache Traffic Server. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.7% (higher than 86% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)2.7%top 13.8% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

There is a vulnerability in Apache Traffic Server 6.0.0 to 6.2.3, 7.0.0 to 7.1.8, and 8.0.0 to 8.0.5 with a smuggling attack and Transfer-Encoding and Content length headers. Upgrade to versions 7.1.9 and 8.0.6 or later versions.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12trafficserver8.0.6+ds-1DEBIAN-CVE-2020-1944

Affected products (as reported)

VendorProductVersions
n/a Apache Traffic Server Apache Traffic Server 6.0.0 to 6.2.3, 7.0.0 to 7.1.8, and 8.0.0 to 8.0.5

References