Vulnerability · Published Jan 30, 2020 · Assigned by apache

CVE-2020-1931

High 8.1

In plain English

A high-severity security flaw in Apache SpamAssassin from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 6.5% (higher than 94% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)8.1High
Exploit odds (30 days)6.5%top 6.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

A command execution issue was found in Apache SpamAssassin prior to 3.4.3. Carefully crafted nefarious Configuration (.cf) files can be configured to run system commands similar to CVE-2018-11805. This issue is less stealthy and attempts to exploit the issue will throw warnings. Thanks to Damian Lukowski at credativ for reporting the issue ethically. With this bug unpatched, exploits can be injected in a number of scenarios though doing so remotely is difficult. In addition to upgrading to SA 3.4.4, we again recommend that users should only use update channels or 3rd party .cf files from trusted places.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20spamassassin3.4.4-r0ALPINE-CVE-2020-1931
Alpine:v3.21spamassassin3.4.4-r0ALPINE-CVE-2020-1931
Alpine:v3.22spamassassin3.4.4-r0ALPINE-CVE-2020-1931
Alpine:v3.23spamassassin3.4.4-r0ALPINE-CVE-2020-1931
Alpine:v3.24spamassassin3.4.4-r0ALPINE-CVE-2020-1931
Debian:12spamassassin3.4.4~rc1-1DEBIAN-CVE-2020-1931
Debian:13spamassassin3.4.4~rc1-1DEBIAN-CVE-2020-1931
Debian:14spamassassin3.4.4~rc1-1DEBIAN-CVE-2020-1931

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache SpamAssassin prior to 3.4.3

References