Vulnerability · Published Aug 26, 2020 · Assigned by mitre
CVE-2020-16251
High 8.2
In plain English
A high-severity security flaw in the github.com/hashicorp/vault package (Go). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.8% (higher than 87% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)8.2High
Exploit odds (30 days)2.8%top 13.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/hashicorp/vault | 1.2.5 | GHSA-4mp7-2m29-gqxf |
| Go | github.com/hashicorp/vault | 1.3.8 | GHSA-4mp7-2m29-gqxf |
| Go | github.com/hashicorp/vault | 1.4.4 | GHSA-4mp7-2m29-gqxf |
| Go | github.com/hashicorp/vault | 1.5.1 | GHSA-4mp7-2m29-gqxf |
| Go | github.com/hashicorp/vault | 1.2.5, 1.3.8, 1.4.4, 1.5.1 | GO-2024-2488 |