Vulnerability · Published Oct 30, 2020 · Assigned by GitHub_M
CVE-2020-15273Cross-Site Scripting in baserCMS
High 7.3
In plain English
A high-severity cross-site scripting in basercms from baserproject. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
baserCMS before version 4.4.1 is vulnerable to Cross-Site Scripting. The issue affects the following components: Edit feed settings, Edit widget area, Sub site new registration, New category registration. Arbitrary JavaScript may be executed by entering specific characters in the account that can access the file upload function category list, subsite setting list, widget area edit, and feed list on the management screen. The issue was introduced in version 4.0.0. It is fixed in version 4.4.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | baserproject/basercms | 4.4.1 | GHSA-wpww-4jf4-4hx8 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| baserproject | basercms | >= 4.0.0, < 4.4.1 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N