Vulnerability · Published Oct 26, 2020 · Assigned by GitHub_M

CVE-2020-15271Shell Command Execution in lookatme

Critical 9.3

In plain English

A critical-severity OS command injection in lookatme from d0c-s4vage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.3% (higher than 83% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.3Critical
Exploit odds (30 days)2.3%top 16.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In lookatme (python/pypi package) versions prior to 2.3.0, the package automatically loaded the built-in "terminal" and "file_loader" extensions. Users that use lookatme to render untrusted markdown may have malicious shell commands automatically run on their system. This is fixed in version 2.3.0. As a workaround, the `lookatme/contrib/terminal.py` and `lookatme/contrib/file_loader.py` files may be manually deleted. Additionally, it is always recommended to be aware of what is being rendered with lookatme.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12lookatme2.3.0-1DEBIAN-CVE-2020-15271
Debian:13lookatme2.3.0-1DEBIAN-CVE-2020-15271
Debian:14lookatme2.3.0-1DEBIAN-CVE-2020-15271
PyPIlookatme2.3.0GHSA-c84h-w6cr-5v8q
PyPIlookatme2.3.0PYSEC-2020-61

Affected products (as reported)

VendorProductVersions
d0c-s4vage lookatme < 2.3.0

Weakness: CWE-78 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N

References