Vulnerability · Published Oct 19, 2020 · Assigned by GitHub_M
CVE-2020-15263XSS in platform
High 8.0
In plain English
A high-severity cross-site scripting in platform from orchidsoftware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)8.0High
Exploit odds (30 days)0.7%top 44.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
In platform before version 9.4.4, inline attributes are not properly escaped. If the data that came from users was not escaped, then an XSS vulnerability is possible. The issue was introduced in 9.0.0 and fixed in 9.4.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | orchid/platform | 9.4.4 | GHSA-589w-hccm-265x |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| orchidsoftware | platform | >= 9.0.0, < 9.4.4 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N