Vulnerability · Published Oct 21, 2020 · Assigned by GitHub_M
CVE-2020-15244RCE in Magento
High 8.0
In plain English
A high-severity unsafe deserialization in magento-lts from OpenMage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)8.0High
Exploit odds (30 days)1.3%top 30.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
In Magento (rubygems openmage/magento-lts package) before versions 19.4.8 and 20.0.4, an admin user can generate soap credentials that can be used to trigger RCE via PHP Object Injection through product attributes and a product. The issue is patched in versions 19.4.8 and 20.0.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | openmage/magento-lts | 19.4.8 | GHSA-jrgf-vfw2-hj26 |
| Packagist | openmage/magento-lts | 20.0.4 | GHSA-jrgf-vfw2-hj26 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenMage | magento-lts | < 19.4.8>= 20.0.0, < 20.0.4 |
Weakness: CWE-502, CWE-74 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H