Vulnerability · Published Oct 21, 2020 · Assigned by GitHub_M

CVE-2020-15240Regression in JWT Signature Validation

High 7.4

In plain English

A high-severity improper authentication in omniauth-auth0 from auth0. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.4High
Exploit odds (30 days)0.8%top 43.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

omniauth-auth0 (rubygems) versions >= 2.3.0 and < 2.4.1 improperly validate the JWT token signature when using the `jwt_validator.verify` method. Improper validation of the JWT token signature can allow an attacker to bypass authentication and authorization. You are affected by this vulnerability if all of the following conditions apply: 1. You are using `omniauth-auth0`. 2. You are using `JWTValidator.verify` method directly OR you are not authenticating using the SDK’s default Authorization Code Flow. The issue is patched in version 2.4.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsomniauth-auth02.4.1GHSA-58r4-h6v8-jcvm

Affected products (as reported)

VendorProductVersions
auth0 omniauth-auth0 >= 2.3.0, <2.4.1

Weakness: CWE-287, CWE-347 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

References