Vulnerability · Published Sep 17, 2020 · Assigned by GitHub_M

CVE-2020-15187Duplicate plugin entries in Helm

Low 3.0

In plain English

A low-severity injection in helm from helm. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 75% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.0Low
Exploit odds (30 days)1.5%top 25.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In Helm before versions 2.16.11 and 3.3.2, a Helm plugin can contain duplicates of the same entry, with the last one always used. If a plugin is compromised, this lowers the level of access that an attacker needs to modify a plugin's install hooks, causing a local execution attack. To perform this attack, an attacker must have write access to the git repository or plugin archive (.tgz) while being downloaded (which can occur during a MITM attack on a non-SSL connection). This issue has been patched in Helm 2.16.11 and Helm 3.3.2. As a possible workaround make sure to install plugins using a secure connection protocol like SSL.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gohelm.sh/helm2.16.11GHSA-c52f-pq47-2r9j
Gohelm.sh/helm/v33.3.2GHSA-c52f-pq47-2r9j

Affected products (as reported)

VendorProductVersions
helm helm >= 2.0.0, < 2.16.11>= 3.0.0, < 3.3.2

Weakness: CWE-694, CWE-74 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:N

References