Vulnerability · Published Sep 17, 2020 · Assigned by GitHub_M

CVE-2020-15186Improper sanitization of plugin names in Helm

Low 3.4

In plain English

A low-severity improper input validation in helm from helm. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.4Low
Exploit odds (30 days)1.0%top 38.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In Helm before versions 2.16.11 and 3.3.2 plugin names are not sanitized properly. As a result, a malicious plugin author could use characters in a plugin name that would result in unexpected behavior, such as duplicating the name of another plugin or spoofing the output to `helm --help`. This issue has been patched in Helm 3.3.2. A possible workaround is to not install untrusted Helm plugins. Examine the `name` field in the `plugin.yaml` file for a plugin, looking for characters outside of the [a-zA-Z0-9._-] range.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gohelm.sh/helm2.16.11GHSA-m54r-vrmv-hw33
Gohelm.sh/helm/v33.3.2GHSA-m54r-vrmv-hw33

Affected products (as reported)

VendorProductVersions
helm helm >= 2.0.0, < 2.16.11>= 3.0.0, < 3.3.2

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:L/A:N

References