Vulnerability · Published Sep 11, 2020 · Assigned by GitHub_M

CVE-2020-15169XSS in Action View

Medium 5.4

In plain English

A medium-severity cross-site scripting in actionview from rails. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.4% (higher than 84% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)2.4%top 16.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling1Public PoC

Official description

In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rails2:6.0.3.3+dfsg-1DEBIAN-CVE-2020-15169
Debian:13rails2:6.0.3.3+dfsg-1DEBIAN-CVE-2020-15169
Debian:14rails2:6.0.3.3+dfsg-1DEBIAN-CVE-2020-15169
RubyGemsactionview5.2.4.4GHSA-cfjv-5498-mph5
RubyGemsactionview6.0.3.3GHSA-cfjv-5498-mph5
Ubuntu:24.04:LTSrailsno fix listedUBUNTU-CVE-2020-15169
Ubuntu:25.10railsno fix listedUBUNTU-CVE-2020-15169
Ubuntu:26.04:LTSrailsno fix listedUBUNTU-CVE-2020-15169
Ubuntu:26.10railsno fix listedUBUNTU-CVE-2020-15169

Affected products (as reported)

VendorProductVersions
rails actionview < 5.2.4.4>= 6.0.0.0, < 6.0.3.3

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N

References