Vulnerability · Published Aug 28, 2020 · Assigned by GitHub_M
CVE-2020-15154Cross Site Scripting in baserCMS
High 7.3
In plain English
A high-severity cross-site scripting in basercms from baserproject. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) via arbitrary script execution. Admin access is required to exploit this vulnerability. The affected components are: content_fields.php, content_info.php, content_options.php, content_related.php, index_list_tree.php, jquery.bcTree.js. The issue is fixed in version 4.3.7.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | baserproject/basercms | 4.3.7 | GHSA-cpxc-67rc-c775 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| baserproject | basercms | unspecified – before < 4.3.7 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N
References
- https://github.com/baserproject/basercms/security/advisories/GHSA-cpxc-67rc-c775 x_refsource_CONFIRM
- https://basercms.net/security/20200827 x_refsource_MISC