Vulnerability · Published Aug 19, 2020 · Assigned by GitHub_M

CVE-2020-15151Observable Timing Discrepancy in OpenMage LTS

High 8.0

In plain English

A high-severity security flaw in magento-lts from OpenMage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.0High
Exploit odds (30 days)0.9%top 39.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

OpenMage LTS before versions 19.4.6 and 20.0.2 allows attackers to circumvent the `fromkey protection` in the Admin Interface and increases the attack surface for Cross Site Request Forgery attacks. This issue is related to Adobe's CVE-2020-9690. It is patched in versions 19.4.6 and 20.0.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistopenmage/magento-lts19.4.6GHSA-crf2-xm6x-46p6
Packagistopenmage/magento-lts20.0.2GHSA-crf2-xm6x-46p6

Affected products (as reported)

VendorProductVersions
OpenMage magento-lts < 19.4.6">= 20.0.0, < 20.0.2

Weakness: CWE-203 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N

References