Vulnerability · Published Sep 1, 2020 · Assigned by GitHub_M
CVE-2020-15150Remote Code Execution in paginator(hex)
Critical 9.0
In plain English
A critical-severity code injection in paginator from duffelhq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.3% (higher than 89% of all known vulnerabilities).
Official description
There is a vulnerability in Paginator (Elixir/Hex package) which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the paginate() function. This will potentially affect all current users of Paginator prior to version 1.0.0. The vulnerability has been patched in version 1.0.0 and all users should upgrade to this version immediately. Note that this patched version uses a dependency that requires an Elixir version >=1.5.
Affected products (as reported)
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
References
- https://github.com/duffelhq/paginator/security/advisories/GHSA-w98m-2xqg-9cvj x_refsource_CONFIRM
- https://hex.pm/packages/paginator x_refsource_CONFIRM
- https://github.com/duffelhq/paginator/commit/bf45e92602e517c75aea0465efc35cd661d9ebf8 x_refsource_CONFIRM
- https://github.com/duffelhq/paginator/blob/ccf0f37fa96347cc8c8a7e9eb2c64462cec4b2dc/README.md#security-considerations x_refsource_CONFIRM