Vulnerability · Published Sep 15, 2020 · Assigned by GitHub_M
CVE-2020-15148Unsafe deserialization in Yii 2
High 8.9
In plain English
A high-severity unsafe deserialization in yii2 from yiisoft. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 77.5% (higher than 99.6% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Yii 2 (yiisoft/yii2) before version 2.0.38 is vulnerable to remote code execution if the application calls `unserialize()` on arbitrary user input. This is fixed in version 2.0.38. A possible workaround without upgrading is available in the linked advisory.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | yiisoft/yii2 | 2.0.38 | GHSA-699q-wcff-g9mj |
Affected products (as reported)
Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:H