Vulnerability · Published Aug 19, 2020 · Assigned by GitHub_M
CVE-2020-15143Remote Code Execution in SyliusResourceBundle
High 7.7
In plain English
A high-severity injection in SyliusResourceBundle from Sylius. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.9% (higher than 80% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In SyliusResourceBundle before versions 1.3.14, 1.4.7, 1.5.2 and 1.6.4, rrequest parameters injected inside an expression evaluated by `symfony/expression-language` package haven't been sanitized properly. This allows the attacker to access any public service by manipulating that request parameter, allowing for Remote Code Execution. This issue has been patched for versions 1.3.14, 1.4.7, 1.5.2 and 1.6.4. Versions prior to 1.3 were not patched.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | sylius/resource-bundle | 1.4.7 | GHSA-p4pj-9g59-4ppv |
| Packagist | sylius/resource-bundle | 1.5.2 | GHSA-p4pj-9g59-4ppv |
| Packagist | sylius/resource-bundle | 1.6.4 | GHSA-p4pj-9g59-4ppv |
| Packagist | sylius/resource-bundle | 1.3.14 | GHSA-p4pj-9g59-4ppv |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Sylius | SyliusResourceBundle | < 1.3.14>= 1.4.0 , < 1.4.7>= 1.5.0, < 1.5.2>= 1.6.0, < 1.6.4 |
Weakness: CWE-74 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N