Vulnerability · Published Aug 7, 2020 · Assigned by GitHub_M
CVE-2020-15138Cross-Site Scripting in Prism
High 7.1
In plain English
A high-severity cross-site scripting in prism from PrismJS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.0% (higher than 81% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-prismjs | 1.11.0+dfsg-4 | DEBIAN-CVE-2020-15138 |
| Debian:13 | node-prismjs | 1.11.0+dfsg-4 | DEBIAN-CVE-2020-15138 |
| Debian:14 | node-prismjs | 1.11.0+dfsg-4 | DEBIAN-CVE-2020-15138 |
| npm | prismjs | 1.21.0 | GHSA-wvhm-4hhf-97x9 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L