Vulnerability · Published Jul 31, 2020 · Assigned by GitHub_M

CVE-2020-15134Missing TLS certificate verification in Faye

High 8.0

In plain English

A high-severity improper certificate validation in faye from faye. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.0High
Exploit odds (30 days)0.9%top 41.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Faye before version 1.4.0, there is a lack of certification validation in TLS handshakes. Faye uses em-http-request and faye-websocket in the Ruby version of its client. Those libraries both use the `EM::Connection#start_tls` method in EventMachine to implement the TLS handshake whenever a `wss:` URL is used for the connection. This method does not implement certificate verification by default, meaning that it does not check that the server presents a valid and trusted TLS certificate for the expected hostname. That means that any `https:` or `wss:` connection made using these libraries is vulnerable to a man-in-the-middle attack, since it does not confirm the identity of the server it is connected to. The first request a Faye client makes is always sent via normal HTTP, but later messages may be sent via WebSocket. Therefore it is vulnerable to the same problem that these underlying libraries are, and we needed both libraries to support TLS verification before Faye could claim to do the same. Your client would still be insecure if its initial HTTPS request was verified, but later WebSocket connections were not. This is fixed in Faye v1.4.0, which enables verification by default. For further background information on this issue, please see the referenced GitHub Advisory.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-faye1.4.0-1DEBIAN-CVE-2020-15134
RubyGemsfaye1.4.0GHSA-3q49-h8f9-9fr9
Ubuntu:22.04:LTSruby-fayeno fix listedUBUNTU-CVE-2020-15134
Ubuntu:24.04:LTSruby-fayeno fix listedUBUNTU-CVE-2020-15134

Affected products (as reported)

VendorProductVersions
faye faye < 1.4.0

Weakness: CWE-295 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N

References