Vulnerability · Published Jul 30, 2020 · Assigned by GitHub_M
CVE-2020-15131False-positive validity for NFT1 genesis transactions in SLP Validate
High 7.5
In plain English
A high-severity security flaw in slp-validate.js from simpleledger. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In SLP Validate (npm package slp-validate) before version 1.2.2, there is a vulnerability to false-positive validation outcomes for the NFT1 Child Genesis transaction type. A poorly implemented SLP wallet or opportunistic attacker could create a seemingly valid NFT1 child token without burning any of the NFT1 Group token type as is required by the NFT1 specification. This is fixed in version 1.2.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | slp-validate | 1.2.2 | GHSA-6jmr-jfh7-xg3h |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| simpleledger | slp-validate.js | < 1.2.2 |
Weakness: CWE-697 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N