Vulnerability · Published Jul 15, 2020 · Assigned by GitHub_M
CVE-2020-15107x87 FPU operations in enclaves are vulnerable to ABI poisoning in openenclave
Medium 5.3
In plain English
A medium-severity security flaw in openenclave from openenclave. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities).
Official description
In openenclave before 0.10.0, enclaves that use x87 FPU operations are vulnerable to tampering by a malicious host application. By violating the Linux System V Application Binary Interface (ABI) for such operations, a host app can compromise the execution integrity of some x87 FPU operations in an enclave. Depending on the FPU control configuration of the enclave app and whether the operations are used in secret-dependent execution paths, this vulnerability may also be used to mount a side-channel attack on the enclave. This has been fixed in 0.10.0 and the current master branch. Users will need to recompile their applications against the patched libraries to be protected from this vulnerability.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| openenclave | openenclave | < 0.10.0 |