Vulnerability · Published Sep 2, 2020 · Assigned by GitHub_M

CVE-2020-15094RCE in Symfony

High 8.0

In plain English

A high-severity security flaw in symfony from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.0% (higher than 88% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.0High
Exploit odds (30 days)3.0%top 12.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In Symfony before versions 4.4.13 and 5.1.5, the CachingHttpClient class from the HttpClient Symfony component relies on the HttpCache class to handle requests. HttpCache uses internal headers like X-Body-Eval and X-Body-File to control the restoration of cached responses. The class was initially written with surrogate caching and ESI support in mind (all HTTP calls come from a trusted backend in that scenario). But when used by CachingHttpClient and if an attacker can control the response for a request being made by the CachingHttpClient, remote code execution is possible. This has been fixed in versions 4.4.13 and 5.1.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12symfony4.4.13+dfsg-1DEBIAN-CVE-2020-15094
Debian:13symfony4.4.13+dfsg-1DEBIAN-CVE-2020-15094
Debian:14symfony4.4.13+dfsg-1DEBIAN-CVE-2020-15094
Packagistsymfony/http-kernel5.1.5GHSA-754h-5r27-7x3r
Packagistsymfony/http-kernel4.4.13GHSA-754h-5r27-7x3r
Packagistsymfony/symfony5.1.5GHSA-754h-5r27-7x3r
Packagistsymfony/symfony4.4.13GHSA-754h-5r27-7x3r

Affected products (as reported)

VendorProductVersions
symfony symfony >= 4.4.0, < 4.4.13>= 5.0.0, < 5.1.5

Weakness: CWE-212 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H

References