Vulnerability · Published Jul 29, 2020 · Assigned by GitHub_M
CVE-2020-15086Potential Remote Code Execution in TYPO3 with mediace extension
Critical 9.8
In plain English
A critical-severity improper input validation in mediace from FriendsOfTYPO3. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.6% (higher than 89% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In TYPO3 installations with the "mediace" extension from version 7.6.2 and before version 7.6.5, it has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. The allows to inject arbitrary data having a valid cryptographic message authentication code and can lead to remote code execution. To successfully exploit this vulnerability, an attacker must have access to at least one `Extbase` plugin or module action in a TYPO3 installation. This is fixed in version 7.6.5 of the "mediace" extension for TYPO3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | friendsoftypo3/mediace | 7.6.5 | GHSA-4h44-w6fm-548g |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| FriendsOfTYPO3 | mediace | >= 7.6.2, < 7.6.5 |
Weakness: CWE-20, CWE-325, CWE-502, CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H