Vulnerability · Published Jun 30, 2020 · Assigned by GitHub_M
CVE-2020-15084Authorization bypass in express-jwt
High 7.7
In plain English
A high-severity security flaw in express-jwt from auth0. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In express-jwt (NPM package) up and including version 5.3.3, the algorithms entry to be specified in the configuration is not being enforced. When algorithms is not specified in the configuration, with the combination of jwks-rsa, it may lead to authorization bypass. You are affected by this vulnerability if all of the following conditions apply: - You are using express-jwt - You do not have **algorithms** configured in your express-jwt configuration. - You are using libraries such as jwks-rsa as the **secret**. You can fix this by specifying **algorithms** in the express-jwt configuration. See linked GHSA for example. This is also fixed in version 6.0.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | express-jwt | 6.0.0 | GHSA-6g6m-m6h5-w9gf |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| auth0 | express-jwt | <= 5.3.3 |
Weakness: CWE-285 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N