Vulnerability · Published May 14, 2020 · Assigned by apache

CVE-2020-11972

Critical 9.8

In plain English

A critical-severity security flaw in Apache Camel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 5.7% (higher than 93% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)5.7%top 7.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Apache Camel RabbitMQ enables Java deserialization by default. Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.0, 3.0.0 up to 3.1.0 are affected. 2.x users should upgrade to 2.25.1, 3.x users should upgrade to 3.2.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.camel:camel-rabbitmq2.25.1GHSA-2x6r-7427-95cm
Mavenorg.apache.camel:camel-rabbitmq3.2.0GHSA-2x6r-7427-95cm

Affected products (as reported)

VendorProductVersions
n/a Apache Camel Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.0, 3.0.0 up to 3.1.0

References