Vulnerability · Published May 22, 2020 · Assigned by GitHub_M

CVE-2020-11076HTTP Smuggling via Transfer-Encoding Header in Puma

High 7.5

In plain English

A high-severity security flaw in puma from puma. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 4.1% (higher than 91% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)4.1%top 9.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling1Public PoC

Official description

In Puma (RubyGem) before 4.3.4 and 3.12.5, an attacker could smuggle an HTTP response, by using an invalid transfer-encoding header. The problem has been fixed in Puma 3.12.5 and Puma 4.3.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12puma4.3.6-1DEBIAN-CVE-2020-11076
Debian:13puma4.3.6-1DEBIAN-CVE-2020-11076
Debian:14puma4.3.6-1DEBIAN-CVE-2020-11076
RubyGemspuma3.12.5GHSA-x7jg-6pwg-fx5h
RubyGemspuma4.3.4GHSA-x7jg-6pwg-fx5h

Affected products (as reported)

VendorProductVersions
puma puma < 3.12.5>= 4.0.0, < 4.3.4

Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References