Vulnerability · Published May 29, 2020 · Assigned by GitHub_M
CVE-2020-11041Improper Validation of Array Index in FreeRDP
Low 2.2
In plain English
A low-severity security flaw in FreeRDP from FreeRDP. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In FreeRDP less than or equal to 2.0.0, an outside controlled array index is used unchecked for data used as configuration for sound backend (alsa, oss, pulse, ...). The most likely outcome is a crash of the client instance followed by no or distorted sound or a session disconnect. If a user cannot upgrade to the patched version, a workaround is to disable sound for the session. This has been patched in 2.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | freerdp-devel | 2:2.1.1-1.el8 | ALSA-2020:4647 |
| AlmaLinux:8 | vinagre | 3.22.0-23.el8 | ALSA-2020:4647 |
| Debian:12 | freerdp2 | 2.1.1+dfsg1-1 | DEBIAN-CVE-2020-11041 |
| Rocky Linux:8 | vinagre | 0:3.22.0-23.el8 | RLSA-2020:4647 |
Affected products (as reported)
Weakness: CWE-129 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:L