Vulnerability · Published Apr 30, 2020 · Assigned by GitHub_M

CVE-2020-11028Unauthenticated disclosure of certain private posts in WordPress

Medium 5.8

In plain English

A medium-severity improper access control in WordPress from WordPress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.3% (higher than 84% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.8Medium
Exploit odds (30 days)2.3%top 16.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In affected versions of WordPress, some private posts, which were previously public, can result in unauthenticated disclosure under a specific set of conditions. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12wordpress5.4.1+dfsg1-1DEBIAN-CVE-2020-11028
Debian:13wordpress5.4.1+dfsg1-1DEBIAN-CVE-2020-11028
Debian:14wordpress5.4.1+dfsg1-1DEBIAN-CVE-2020-11028
Ubuntu:22.04:LTSwordpressno fix listedUBUNTU-CVE-2020-11028
Ubuntu:24.04:LTSwordpressno fix listedUBUNTU-CVE-2020-11028
Ubuntu:25.10wordpressno fix listedUBUNTU-CVE-2020-11028
Ubuntu:26.04:LTSwordpressno fix listedUBUNTU-CVE-2020-11028
Ubuntu:26.10wordpressno fix listedUBUNTU-CVE-2020-11028

Affected products (as reported)

VendorProductVersions
WordPress WordPress >= 5.4.0, < 5.4.1>= 5.3.0, < 5.3.3>= 5.2.0, < 5.2.6>= 5.1.0, < 5.1.5>= 5.0.0, < 5.0.9>= 4.9.0, < 4.9.14>= 4.8.0, < 4.8.13>= 4.7.0, < 4.7.17

Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N

References