Vulnerability · Published Apr 30, 2020 · Assigned by GitHub_M

CVE-2020-11027Password reset links invalidation issue in WordPress

Medium 6.1

In plain English

A medium-severity security flaw in WordPress from WordPress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 13.6% (higher than 96% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)13.6%top 3.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In affected versions of WordPress, a password reset link emailed to a user does not expire upon changing the user password. Access would be needed to the email account of the user by a malicious party for successful execution. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12wordpress5.4.1+dfsg1-1DEBIAN-CVE-2020-11027
Debian:13wordpress5.4.1+dfsg1-1DEBIAN-CVE-2020-11027
Debian:14wordpress5.4.1+dfsg1-1DEBIAN-CVE-2020-11027
Ubuntu:22.04:LTSwordpressno fix listedUBUNTU-CVE-2020-11027
Ubuntu:24.04:LTSwordpressno fix listedUBUNTU-CVE-2020-11027
Ubuntu:25.10wordpressno fix listedUBUNTU-CVE-2020-11027
Ubuntu:26.04:LTSwordpressno fix listedUBUNTU-CVE-2020-11027
Ubuntu:26.10wordpressno fix listedUBUNTU-CVE-2020-11027

Affected products (as reported)

VendorProductVersions
WordPress WordPress >= 5.4.0, < 5.4.1>= 5.3.0, < 5.3.3>= 5.2.0, < 5.2.6>= 5.1.0, < 5.1.5>= 5.0.0, < 5.0.9>= 4.9.0, < 4.9.14>= 4.8.0, < 4.8.13>= 4.7.0, < 4.7.17

Weakness: CWE-672 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N

References