Vulnerability · Published Apr 10, 2020 · Assigned by GitHub_M

CVE-2020-11002Remote Code Execution (RCE) vulnerability in dropwizard-validation

High 8.0

In plain English

A high-severity injection in dropwizard from dropwizard. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 5.2% (higher than 92% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.0High
Exploit odds (30 days)5.2%top 7.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

dropwizard-validation before versions 2.0.3 and 1.3.21 has a remote code execution vulnerability. A server-side template injection was identified in the self-validating feature enabling attackers to inject arbitrary Java EL expressions, leading to Remote Code Execution (RCE) vulnerability. If you are using a self-validating bean an upgrade to Dropwizard 1.3.21/2.0.3 or later is strongly recommended. The changes introduced in Dropwizard 1.3.19 and 2.0.2 for CVE-2020-5245 unfortunately did not fix the underlying issue completely. The issue has been fixed in dropwizard-validation 1.3.21 and 2.0.3 or later. We strongly recommend upgrading to one of these versions.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenio.dropwizard:dropwizard-validation1.3.21GHSA-8jpx-m2wh-2v34
Mavenio.dropwizard:dropwizard-validation2.0.3GHSA-8jpx-m2wh-2v34

Affected products (as reported)

VendorProductVersions
dropwizard dropwizard < 1.3.21>= 2.0.0, < 2.0.3

Weakness: CWE-74 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H

References