Vulnerability · Published Apr 14, 2020 · Assigned by GitHub_M

CVE-2020-11001Possible XSS attack in Wagtail

Medium 5.8

In plain English

A medium-severity cross-site scripting in wagtail from wagtail. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.8Medium
Exploit odds (30 days)1.3%top 30.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In Wagtail before versions 2.8.1 and 2.7.2, a cross-site scripting (XSS) vulnerability exists on the page revision comparison view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft a page revision history that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 2.7.2 (for the LTS 2.7 branch) and Wagtail 2.8.1 (for the current 2.8 branch).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIwagtail2.7.2GHSA-v2wc-pfq2-5cm6
PyPIwagtail2.8.1GHSA-v2wc-pfq2-5cm6
PyPIwagtail2.7.2PYSEC-2020-152

Affected products (as reported)

VendorProductVersions
wagtail wagtail < 2.7.2>= 2.8.0, < 2.8.1

Weakness: CWE-80, CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N

References